R1:
ena
conf t
interface gigaethernet 0/1
ip address 192.168.10.1 255.255.255.0
no sh
interface gigaethernet 0/0
ip address 192.168.20.1 255.255.255.0
no sh
exit
copy run start
Switch>enable
Switch#configure terminal
Switch(config)#hostname S1
S1yS2(config)#enable secret class
S1yS2(config)#no ip domain-lookup
S1yS2(config)#line console 0
S1yS2(config-line)#password cisco
S1yS2(config-line)#login
S1yS2(config-line)#line vty 0 15
S1yS2(config-line)#password cisco
S1yS2(config-line)#login
S1yS2(config-line)#end
S1yS2#copy running-config startup-config
S1:
vlan 10
name students
vlan 20
name faculty-admin
interface fa0/1
switchport mode trunk
no shutdown
interface range fa0/5-6
switchport mode access
switchport access vlan 10
no shutdown
exit
interface vlan 10
ip address 192.168.10.11 255.255.255.0
no sh
exit
ip default getaway 192.168.10.1 255.255.255.0
exitcopy run start
vlan 10
name students
vlan 20
name faculty-admin
interface fa0/1
switchport mode trunk
no shutdown
interface range fa0/11-18
switchport mode access
switchport access vlan 20
no shutdown
exit
interface vlan 20
ip address 192.168.10.12 255.255.255.0
no sh
exit
ip default getaway 192.168.10.1 255.255.255.0
exitcopy run start
verificar todo:
SHOW IP ROUTE
SHOW INTERFACE TRUNK
SHOW VLAN BRIEF
fa0/1 es un enlace tronkal y no está asignado a ninguna VLAN, por eso no sale!
Sí se hacen pings!!!
CONCLUSIÓN:
Los enlaces entre switchs y routers son relativamente fáciles poque no hay que configurar nada, estamos haciendo inter-VLAN-routing de manera clásica así que no se requieren subinterfaces en el router. Pero ahora Rubén a mandado que nos zumbemos la conexión entre S2 y R1.
De manera que ahora debemos hacer ROUTER-ON-A-STICK y crear subinterfaces:
R1:
ena
conf t
interface gigaethernet 0/1.10
encapsulation dot1q 10
ip address 192.168.10.1 255.255.255.0
no sh
interface gigaethernet 0/1.20
encapsulation dot1q 20
ip address 192.168.20.1 255.255.255.0
no sh
exit
copy run start
No hay comentarios:
Publicar un comentario